Forum: Hardware Technical Support - Topic: Numark V7 - Setup - 1 and 2 unit settings - Page: 1

Questions or comments about the supported hardware by VirtualDJ, Numark Cue, Virtual Vinyl or AtomixMP3.
For general troubleshooting and MIDI controller configuration, please see Config & Troubleshooting.
Hardware products
VirtualDJ forums
Hardware Technical...
Numark V7 -...

Page : [>] [>>]


Auteur - Sujet Numark V7 - Setup - 1 and 2 unit settings -

cstoll
PRO Infinity
Member since 2004

Honorary Member
Posté Sat 03 Jul 10 @ 3:10 pm
- Numark V7 -

Until the next update release - download and use this definition:
- Removed - V7s are now natively supported - no downloading of definitions necessary

- Drivers -

Install the latest drivers for your appropriate OS bit version -

** First recommend installing the latest version of Itch to get any firmware updates and the latest drivers. However you can get the latest AUDIO Only drivers from the Numark site. Firmware upgrades are only available by installing ITCH.

You do not need to install these drivers if you have installed the latest version of ITCH.
Windows 64-bit - http://www.numark.com/content255772.html
Windows 32-bit - http://www.numark.com/content252076.html

Mac OSX - http://www.numark.com/content258500.html



SINGLE UNIT
Windows

Install the V7 - Run the driver install and follow the steps of the installer - use the drivers from the Numark site above.

After the restart and back at Windows - Open VirtualDJ go to the Config - Sound card setup
Select -

  1. Inputs - None
  2. Outputs - External Mixer (Left Deck - Chan 1&2 / Right Deck - Chan 3&4)
  3. Sound Card - ASIO
  4. Select the V7 USB Audio Device as the soundcard with Ultra-latency ASIO checked
  5. Click Apply


Click OK to return to the VirtualDJ interface.

Mac OSX

Install the V7 - Run the driver install and follow the steps of the installer - use the drivers from the Numark site above.

After the restart and back at OSX - Power On the V7

Open VirtualDJ go to the Config - Sound card setup
Select -

  1. Inputs - None
  2. Outputs - External Mixer (Left Deck - Front Output / Right Deck - Rear Output)
  3. Sound Card - 4-Out
  4. Select the Numark V7 as the soundcard
  5. Click Apply


Click OK to return to the VirtualDJ interface.

TWO UNITS
Windows

Install your first V7 (left) - Run the driver install and follow the steps of the installer - use the drivers from the Numark site above.

After the restart and back at Windows -
Connect the 2nd V7 (right) using the following connection - DO NOT use the USB connection.

  1. Run the Link cable from left to right
  2. Put the left V7 in MASTER and Deck Select on A
  3. Put the right V7 Deck Select on B and press the MASTER button so it is OFF
  4. Switch the Deck Position switches on the back to the appropriate position settings (Left < Left || Right > Right)
  5. Connect your RCA Audio cables from the LEFT V7 to your mixer - you can only use 1 Deck as the Audio Output.


Open VirtualDJ go to the Config - Sound card setup
Select -

  1. Inputs - None
  2. Outputs - External Mixer (Left Deck - Chan 1&2 / Right Deck - Chan 3&4)
  3. Sound Card - ASIO
  4. Select the V7 USB Audio Device as the soundcard with Ultra-latency ASIO checked
  5. Click Apply


Click OK to return to the VirtualDJ interface.


Mac OSX


Install the first V7 (Left) - Run the driver install and follow the steps of the installer - use the drivers from the Numark site above.

After the restart and back at OSX - Power On the Left V7

Connect the 2nd V7 (right) using the following connection - DO NOT use the USB connection.

  1. Run the Link cable from left to right
  2. Put the left V7 in MASTER and Deck Select on A
  3. Put the right V7 Deck Select on B and press the MASTER button so it is OFF
  4. Switch the Deck Position switches on the back to the appropriate position settings (Left < Left || Right > Right)
  5. Connect your RCA Audio cables from the LEFT V7 to your mixer - you can only use 1 Deck as the Audio Output.


Open VirtualDJ go to the Config - Sound card setup
Select -

  1. Inputs - None
  2. Outputs - External Mixer (Left Deck - Front Output / Right Deck - Rear Output)
  3. Sound Card - 4-Out
  4. Select the Numark V7 as the soundcard
  5. Click Apply


Click OK to return to the VirtualDJ interface.




Hope these steps help and get you up and running - happy mixing :)

Here is a quick video to help you see that it all works :) Using VirtualDJ Pro on Mac OSX Snow Leopard (10.6.4)




Some pics --

Deck A - note the connections and the Deck Select is on A with MASTER lit with LINK light ON



Deck B - note the Link cable and Power cable are the only thing connected, Deck Select is on B, MASTER is OFF with LINK light ON

JUSTNYCE2
PRO Infinity
Member since 2007

Posté Sun 18 Jul 10 @ 9:16 pm
How/where do you install the xlm definition??

jakovski
PRO Infinity
Member since 2006

Atomix European Operations Manager
Posté Mon 19 Jul 10 @ 9:57 am
Put it in the 'My Documents\Virtual DJ\' path. There is a folder for the definition 'Devices' and one for the mappers 'Mappers'. Just unpack and copy there.

Greets, Heiko

DJJoeski1985
Home user
Member since 2010

Posté Fri 23 Jul 10 @ 2:58 am
Great post... But does the transport section work on the V7? I mean the scroll knob, load A & B and back buttons? Do they control the software?

Thanks

Joeski

cstoll
PRO Infinity
Member since 2004

Honorary Member
Posté Fri 23 Jul 10 @ 9:20 am
Yes - they work ...

DJJoeski1985
Home user
Member since 2010

Posté Fri 23 Jul 10 @ 9:55 am
Thanks...Can you post another video showing deck control and looping features?

artisticdj
PRO Infinity
Member since 2008

Posté Tue 17 Aug 10 @ 1:48 am
Just received my V7, plugged it in, downloaded the drivers as stated, installed, restarted, everything worked. Only thing is when i load songs, they are high pitched, any suggestions on how to fix.

jakovski
PRO Infinity
Member since 2006

Atomix European Operations Manager
Posté Tue 17 Aug 10 @ 5:37 am
Disable 'Auto Pitch' in the config / options tab.

Greets, Heiko

DeAlmaro
PRO Infinity
Member since 2007

Posté Thu 19 Aug 10 @ 5:00 pm
I have one V7 when I install everything im not able to crossfade on my mixer. Its not picking in up unless I do it manually with my mouse. Im using windows 7. Any suggestions

DeAlmaro
PRO Infinity
Member since 2007

Posté Thu 19 Aug 10 @ 5:06 pm
Can the V7 only work with virtual dj if you have 2 V7's not one?

andytaylor125
PRO Infinity
Member since 2006

Posté Fri 20 Aug 10 @ 10:21 am
Nope, you can definitely DJ with just one V7. That's what I'm looking at buying, then getting a second one later.

djtriple9
PRO Infinity
Member since 2009

Posté Sun 22 Aug 10 @ 5:45 pm
works fine with one v7 in win7 and OS X Snow leopard, but I notice a lag in turntable response when switching decks and starting the song. Happens in both OSX and Windows, so I'm guessing it's a hardware issue, but something to note when using just one unit. Also had to have all my bluetooth audio devices removed in order to get it working right in OS X. Also notice performance issues when I had my smart phone plugged in my laptop while playing. None of it's a big deal and I'm not seeing a need for a fix (all that stuff drains on your CPU anyway...) but just thought I share some observations. Keep up the good work CStoll. BTW it interact with my LPD8 quite well...

DeAlmaro
PRO Infinity
Member since 2007

Posté Wed 25 Aug 10 @ 8:19 pm
My crossfader on my mixer is not working with V7, Any suggestions

sbangs
PRO Infinity
Member since 2004

Posté Fri 27 Aug 10 @ 1:30 pm
Unless you have a midi mixer (Midi Crossfader) it will not control Virtual DJ

DeAlmaro
PRO Infinity
Member since 2007

Posté Tue 31 Aug 10 @ 6:24 pm
Thanks for the info

jeffrey tedder
PRO Infinity
Member since 2008

Posté Thu 09 Sep 10 @ 9:16 am
Just recieved my 7's yesterday. Did the install. When I am playing the left player pitch and display seems jumpy on the laptop screen. The right deck plays fine, But sometimes the right deck plays double speed on the initial startup. Any suggestions?

artisticdj
PRO Infinity
Member since 2008

Posté Thu 21 Oct 10 @ 2:32 am
my slave v7 plays in double speed when motor is on, but normal when motor is off. I have switched both v7s to master and slave and it does it on both v7s so I know one of the v7s is not defective. Anybody know how to fix this? It all works fine on the Itch software.

jeffrey tedder
PRO Infinity
Member since 2008

Posté Fri 22 Oct 10 @ 6:43 pm
artisticdj wrote :
my slave v7 plays in double speed when motor is on, but normal when motor is off. I have switched both v7s to master and slave and it does it on both v7s so I know one of the v7s is not defective. Anybody know how to fix this? It all works fine on the Itch software.


I had the same problem briefly last week. It happened as I was going through the different skins. But it is ok now though.

cstoll
PRO Infinity
Member since 2004

Honorary Member
Posté Sat 23 Oct 10 @ 12:07 pm
The Slave deck will spin at double speed if you open VirtualDJ while both decks are in MASTER mode even if you change the slave deck out of master mode before starting to play a track. The 'quick fix' is to just put the 2nd deck in MASTER mode then back to slave mode by pressing the Master button. Remember - if the MASTER button is lit (ON) then it is in Master mode - un-lit (OFF) it is in SLAVE mode.

Also, remember per the instructions above - the MASTER unit should always be the unit with the USB cable connected to the computer - the SLAVE unit is always the one with just the LINK cable connected to it.

DJadamt
PRO Infinity
Member since 2008

Posté Sun 31 Oct 10 @ 8:09 am
Hi, maybe you can help i've had my V7's for a wile & i have a few problems (well big one's) noticed my CPU bar is running quite high & my left deck keeps restarting the track at random times mostly wiles mixing but has restarted a few times wile's just playing. it's always the left (lead deck) anyone else had these problems I thought it may have been my ram so ungraded to 2Gb but not made a diff

Page : [>] [>>]