Forum: VirtualDJ Technical Support

For reporting any bug, questions or comment related to the latest version of VirtualDJ
(NOTE: VirtualDJ continuously updated, so many older topic on this forum are most probably already fixed in the current build)

If you need extended support, contact our Support Team.
Forum Guidelines  (*) The moderators hold the rights to remove, move or modify posts.
Sujet Finally upgrading to Virtual DJ 8.2, scratch problems with VMS4.1

Ce topic est ancien et peut contenir des informations obselètes ou incorrectes.

Hello, I am a long time user of Virtual DJ. While I have had VDJ8 sitting on my laptop since it was released, I haven't really used it much because there were a few things that were deal breakers for me as far as effects, and a few other things I really liked in VDJ7. The short of it is, I've been waiting for a few things to catch up in the VDJ8 world, before moving. I really like customization, and a few certain effects, and I can finally get all of that the way I want it in VDJ 8.

I have been working on making the mapping changes for VDJ8.2 to get everything working on my VMS4.1 the way I had it in VDJ7.4. I've got a lot of it done, but for some reason, my scratch wheels are not working correctly. I tried the default map, and it has the same problem. I even went as far as to move my custom map completely to a different folder on my desktop, to make sure there was no weird interaction going on, such that it was my custom mapping causing the issue somehow. Hence, I tried VDJ8.2 with it's vanilla default VMS4.1 map, and I still have the same issue.

Here is the issues:
1. In vinyl mode, when I try to scratch, it just scans through the track super fast. Like maybe a 1/4 turn of the wheel will take it from one end of the track to the other.
2. In jog mode, it seems to not do a dam thing.

If I bring VDJ 7.4 back up, everything works just fine.

Hoping there is a simple fix here, and it's old news for the VMS4.1 users here that have been running VDJ8 since release.


Thank you in adance :)

Posté Wed 10 Aug 16 @ 6:02 am
djdadPRO InfinityDevelopment ManagerMember since 2005
Do you still have the same issue if you restart VirtualDJ ?

Most likely, you have used SHIFT+JOGwheel (Seek mode) and you have released SHIFT before releasing Jogwheel
The "solution" is to repeat SHIFT +Jogwheel but this time release Jog first and then SHIFT

Can you confirm the above ?

Posté Wed 10 Aug 16 @ 7:55 am
I have tried restarting. I have even gone as far as to completely shut down and restart the computer, and the VMS4.1 as well. Everything works fine in VDJ7.4 still, I only have the issue with VDJ8.2.

If I never want the jog wheel to work as a track seek (I prefer to just use my mouse or a cue point to jump to a location) how can I disable that permanently? Perhaps that will help? I am fairly techy, so I can take a bit of tech talk.... but it's also been a while since I've done a lot of mapping, as I was content for quite a long time with the mapping I did for 7.4.

Also, if there an updated code library/howto for VDJ8? The use to have it on the site before VDJ8, and I used it extensively to create the customized mapping for my VMS4.1 I love so much. I can't seem to find it online.

Thank you again for your help :)

Posté Wed 10 Aug 16 @ 4:03 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
In the key list of the factory default mapping of the unit, there should be a S_JOG_TOUCH key.
replace the assigned action with just

Posté Wed 10 Aug 16 @ 8:23 pm
Thanks! I will give that a try tonight when I get home, and let you know if it works! Thanks again :)

Posté Wed 10 Aug 16 @ 8:45 pm
still no good. I am uninstalling VDJ8.2, and will try a fresh reinstall. It's been patching for probably over a year, so maybe that's what's messed it up? Anyway, here goes. Haven't seen a load of VMS4.1 owners complaining, so I think I've just got a bug going on here.

Posté Thu 11 Aug 16 @ 4:43 am
Okay, so it seems that the problem was not related to anything in the mapping, but some kind of bug this install of virtualdj 8 caught along the process of being originally installed shortly after release, and then just more of less sitting there, collecting updates all the way to the latest 8.2 over time. Perhaps because of me trying different settings with the original 8.0 release, and then having patch after patch added on, something got messed up in the registry entries.

I initially did an uninstall, but left settings and the database along, because I still have 7.4 installed, and it's my solid right now. Still was having the same issues after reinstalling version 8.2... so this time, backed up the entire VDJ folder found in the documents section, as well as the database on drive D: Then did a full uninstall of version 8.2, settings and all. Reinstalled, suddenly everything works, even with the same code for the jogwheel as before. Copied all the contents of the backed up VDJ folder into the new install folder, such that the new install folder would now be exactly the same as before the full uninstall. Everything still works. Hence, if it had been something I was doing with map settings etc, it should have had the problem again, so because it did not have any issues after copying all of the backup contents over (overwriting duplicates), it would seem something got biffed in the registry, and wasn't able to be corrected without a full uninstall.

So the short of it is, it seems to have been just a weird problem that happened on my specific machine, and now it is fixed :) So on to just modifying the mapping till I have 8.2 where I want it :)

Posté Thu 11 Aug 16 @ 3:45 pm
I very much doubt it was related to the registry, because VDJ 8 only uses one registry key. Everything else is stored in the settings.xml file.

Posté Thu 11 Aug 16 @ 3:51 pm

(Les anciens sujets et forums sont automatiquement fermés)