Forum: VirtualDJ Technical Support

For reporting any bug, questions or comment related to the latest version of VirtualDJ
(NOTE: VirtualDJ continuously updated, so many older topic on this forum are most probably already fixed in the current build)

If you need extended support, contact our Support Team.
Forum Guidelines  (*) The moderators hold the rights to move or modify posts in order to keep the discussions clear or to facilitate the search.
Sujet Music skipping, pausing, delay occasionally
djadam2PRO InfinityMember since 2010
I bought a new Dell G7 gaming computer and last Saturday at my wedding, for the first time ever, some of the songs being played had a skipping sound, some of them paused for 1/2 second before resuming play, sometimes is sounds scratchy. I have never had this happen on any of my HP laptops. I am using ASIO drivers, which I have in the past. I have an MC6000 MK2 controller. All the firmware has been updated, currently running VDJ8Pro version 8.3 build 5046. Someone did say the latest upgrade to virtual created some issues?
Please help!! Need it fixed before my next wedding. It’s very embarrassing!
Thank in advance

Posté Wed 17 Jul 19 @ 3:43 pm
PhilWPRO InfinityMember since 2011
I suggest running latencymon to see if your PC is causing the issues. Some manufacturers have poorly-behaved drivers which can show up as audio problems. I believe I’ve read here that Dell is known for this.

You might also want to search these forums for Denon and ASIO - some devices are no longer supported with ASIO due to problems with Denon’s driver. Given that yours still seems to use ASIO, I suspect it’s not included.

Posté Thu 18 Jul 19 @ 2:24 pm
djadam2 wrote :
I bought a new Dell G7 gaming computer and last Saturday at my wedding, for the first time ever, some of the songs being played had a skipping sound, some of them paused for 1/2 second before resuming play, sometimes is sounds scratchy. I have never had this happen on any of my HP laptops. I am using ASIO drivers, which I have in the past. I have an MC6000 MK2 controller. All the firmware has been updated, currently running VDJ8Pro version 8.3 build 5046. Someone did say the latest upgrade to virtual created some issues?
Please help!! Need it fixed before my next wedding. It’s very embarrassing!
Thank in advance


Hello, I have the same problem. I have a brand new powerful laptop so ignore whoever is blaming your computer. It's the VirtualDJ software. They better fix it soon or I'll unsuscribe because it is embarrassing when it happens at the club.


Posté Sun 28 Jul 19 @ 4:58 am
user19956423 wrote :
powerful laptop so ignore whoever is blaming your computer. It's the VirtualDJ software


No, it's not the software. I for one can quite happily play entire gigs without a single audio problem - and that's using an old laptop from the days of Vista (12 years ago).

There are millions of people using VDJ, and only a tiny fraction of those post here with problems.

It doesn't matter how powerful your computer is. If it's not been configured for reliable audio use then you could encounter problems.


Posté Sun 28 Jul 19 @ 6:44 am
NicotuxHome userMember since 2014
I bought a new Dell G7 gaming computer and last Saturday at my wedding
1 - There are two possible problems : Dell computers - as well as some other - often have some issues with their drivers - audio and video -
They often needs some special tweeks and fixes
2 - Computer is recent ... there may be some OS update or even updates pending taking a lot of network CPU and DISC access

for the first time ever, some of the songs being played had a skipping sound, some of them paused for 1/2 second before resuming play, sometimes is sounds scratchy.
This sounds like either some GPU or HDD/SDD overload, which can append on new computer because of previous point 2
But this is not the only one raison : USB 3.0 being one of them, try USB 2x port instead.

I have never had this happen on any of my HP laptops.
Well yes, uptodate and stable HP - and many other PCs - don't have problems

I am using ASIO drivers, which I have in the past. I have an MC6000 MK2 controller. All the firmware has been updated, currently running VDJ8Pro version 8.3 build 5046.
ASIO ... in the past ! There are currently many issues with old ASIO and new Windows 10. And by experience i can say DELL + ASIO + WIN10 1903 is a mess.
Try to configure everything in WASAPI - it worked fine for me

Someone did say the latest upgrade to virtual created some issues?
Of course yes as for any other software


Please help!! Need it fixed before my next wedding. It’s very embarrassing!
Thank in advance
What i can say is :
- Make sure System is fully updated
- Force update of any driver From Dell or DELL dedicated and apply fixes if any
- Use USB 2.x for your controller, USB3.x implement some buffering and don't have constant flaw of data
- Keep sure no background process is taking DISK access and Network i.e. error/log reporting, crash reporting, background update downloading, search indexation, virus scan...
for that you may need to the system to stabilise once booted and wait for some time
- with VDJ running make sure database is uptodate and clean
i.e. recurse your main folder in a way VDJ see all media, then clean database from missing files
- Create an audio config WASAPI based

this helped with my dell

Posté Sun 28 Jul 19 @ 12:00 pm